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LV8548MCSLDGEVB 

Stepper Motor Driver Module Solution Kit 
Quick Start Guide 

Overview 
The LV8548MCSLDGEVB is an ON Semiconductor motor driver 

module featuring the LV8548MC. This module is capable of easily 
driving a stepper motor.   

Motor driving is made easy with Arduino Micro1) compatibility. The 
LV8548MCSLDGEVB comes with a Baseboard for facilitated 
plug-and-play connectivity with an Arduino Micro.  

GUI and Open-source API Functions are available for custom, 
user-specific motor driving programs. 

 
 
 

Features: 

• VCCmax = 20 V, IOmax =1.0 A2)（between OUT_A and B, between 

OUT_C and D） 

• 6～12 V applications Recommended（VCC = 4～16V Max） 

• Standby current consumption = 0 
• Full step, Half step drivability  
• Typical Applications: In-Home Appliances, Consumer Products, 
Industrial Products 
 
For further product information, please visit: 
http://www.onsemi.com/PowerSolutions/product.do?id=LV8548MC 
 

What you need 
• PC  
  Windows 7, 64bit 
Connected to the Internet 
(Only for “Including the TimerOne Libary” on Page3) 

  Arduino IDE 1.8.4 3) Installed 
  User with an Administrator rights 
• Power Supply  

AC Adapter  Output voltage：4～16V 

Output current：～2A 

Connector specification 

Polarization：Positive Center 

Inner diameter＝2.1mm、outer diameter＝5.5mm 

Recommended : WSU075-1000（Triad Magnetics） 

or stabilized DC power supply, dry cell battery, etc. 
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LV8548MCSLDGEVB Board 

 
 

 

 

ONBB4AMGEVB Board with 
Arduino Micro and 
LV8548MCSLDGEVB Board  

 

 
 
 

 
 
 

1) Arduino / Genuino is ArduinoAG are registered trademarks. 

2) Stress exceeding this voltage or current may risk damage to the device. Functionality and reliability may be hindered if the device 

exceeds these values. The maximum current value, IOmax, does not guarantee the module can handle that much current. If the 

device overheats, thermal shutdown will occur. 
3) Contents of kit may not be compatible with different versions. Please see the Appendix attached if specified version is not installed 
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Contents of the Kit 
Hardware 

• LV8548MCSLDGEVB：Motor driver module 

• ONBB4AMGEVB：Baseboard 

• Arduino Micro 
• USB Cable (Micro B-A) 
• USB Thumb Drive  
• Flat-tip Screw Driver  
• Stepper motor MDP-35A (Nidec Seimitsu, Step angle= 7.5 deg, 12V/ 300mA) 1pc 
(Brush DC Motor 1pc) 

 
 
Software (Included in USB Thumb Drive) 

 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

Software Setup 
 
Please download 

  
found on the provided USB flash drive to any 
preferred directory. 
(E.g. Libraries\Documents or Desktop) 

 
 
API Library 
The following process should be operated with the 
Arduino Micro disconnected. 
 
① Double click on the Arduino sketch for GUI  

 This will launch 
the Arduino IDE. 
(Check the Appendix, “How to install Arduino 
IDE”, if the Arduino IDE is not installed)  

 

 
The IDE will display the following message when 
the LV8548_STEP_Program.ino file is opened for 
the first time. Click “OK” to continue. 
 

 
 
This message will be displayed if the .ino file is not 
inside of a folder with the same name. (E.g. 
Sketch12345.ino must be in the Sketch12345 
folder). 
 
 
 
 
 
 
 
 
 
 
 
*Some screen captures are taken from different motor driver modules 

・・・GUI as well as .NET Framework4.6.1 Installer 

 

・・・Arduino IDE Installer 

・・・DC Motor Files 
   （Refer to DC Motor Manual） 

・・・.NET Framework4.6.1 Related Files 

・・・GUI Related Files 

・・・Appendix for supplementary material 

・・・Instructions for operation and setup 

・・・GUI – Arduino Firmware 

・・・API Library 

・・・Installer package in Japanese 
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② Include the API Library 
As shown below, navigate to “Sketch→Include 
Library→Add .Zip Library” 
 

 
 
The following window will appear. Select the 
“LV8548_STEP_APILibrary” folder, and open this 
folder as shown below. 
 
Click the folder only once and push “Open” button. 
Do not double click the folder. 

 
 
Unless updating the function library, including the 
API function library only needs to be done once. 
 
Including the TimerOne Library 
As shown below, navigate to “Sketch→Include 
Library→Manage Libraries” 

 
 
Once the library manager starts up, please type 
“TimerOne” in the search bar at the top 

  
 
 

Select and install “TimerOne” in the search results 

 
 
 
Compiling the Arduino Program 

・Write to Arduino 

 
① Select the Arduino board to upload to by 

navigating to 
“Tools→Board→Arduino/Genuino Micro” 

 
 
② Write an Arduino sketch and navigate to 

“Sketch→Verify/Compile” when finished 
writing 

 
The IDE will display “Done compiling” after a 
successful compile has been verified. 

 
 
 
 
 
 
 
 
 
 
 
 
 
*Some screen captures are taken from different motor driver modules 
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③ Connect the PC to the Arduino Micro via 
USB and select the corresponding COM port 
as shown below 

 
 
④ Upload the sketch by clicking “Sketch→Upload” 

or by pressing the ○→  button 

 
 
In the process of uploading, the Arduino Micro 
bootloader will be installed. 
 

 
 
The IDE will display “Done uploading” after a 
successful upload to the Arduino 

 
 
Sketches written to the Arduino will not be erased 
unless rewritten 
 
If the uploading of the program fails confirm the 

details in step ① check board name and step ③ 

check serial port connection. 
 
 
 
 
 
 
 
 
 
 
 

Rewrite the Arduino Program 

In the case of ① or ② below, please rewrite the 

program to the Arduino 

① When updating the API Function library 
1) Delete the existing API function library by 

navigating to Documents\Arduino\libraries 
and deleting the 
LV8548_STEP_APILibrary folder. 

2) Include the latest API function library. 
Please save the latest API function library 
in your preferred directory on your PC. 
(See Page 2, “Software Setup”) 
Include the latest API function library. 
(See Page 2 “API Library”) 

3) Compile and write the program to the 
Arduino 

(See Page 3, “Writing and Compiling with the 
Arduino IDE”) 

 
② When evaluating the LV8548 DC and other 

motor driver modules 
(Assuming other motor driver module libraries 
have already been included) 
1) Compile and write the program to the 

Arduino 
(See Page 3, “Writing and Compiling with the 

Arduino IDE”) 
 
If you are testing the LV8548 DC module 
library or any other motor driver module library 
for the first time, please operate according to 
their corresponding manual. 
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GUI Installation 
① Double click on                      in the 

 folder and 
proceed with the installation as shown below 
 
*If a previous version of this GUI 
(ON_MD_Module_Kit_GUI) has already been 
installed, please uninstall and reinstall the GUI 
 

② The .NET Framework4.6.1 installation window 
will appear if the PC does not have the 
necessary version. If .NET Framework4.6.1 is 
not installed, click Accept to install. 

 

 
 

The following window shows the installation in 
progress. (This may take several minutes) 
 

 
 

 

If the installation requires a reboot to complete, a 
message will appear on the screen. Please press 
“Yes” to reboot. 
Once rebooted, run                      installation file 
again. 
 

 

 

 

 

 

 

 

③ Install the GUI.  
Press “Next” 

 
 
④ Specify installation folder, or just click “next” to 

continue with the installation 

 
 
Please press “next”. 

User administratiive rights may be required for 
installation. If an alert for user account control is 
displayed, please select “Yes.” 
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The following screen will be displayed after a 
successful installation. 

 
 
 
 
 
 
 
 
 
 

Make sure the GUI shortcut icon is created on the 
desktop as shown below and that the program has 
been added to the Windows start menu. 

 

 
 
 
 

Desktop Shortcut 

Start Menu 
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Hardware Setup 
 

① Connect the LV8548MCSLDGEVB（Motor Driver Module）to the ONBB4AMGEVB（Motor Driver 

Baseboard）. Insert the module into the baseboard, while being careful not to bend the header pins 

② Connect the Arduino/Genuino Micro to the baseboard, as seen in the figure above. The USB connection 
port should be labeled on the baseboard ”USB” to dictate the orientation of the Arduino 

 

 
 

③ Plug in the motor wires (Insulation between 5mm – 10mm) into the output terminals on the baseboard – 
OUT_A/B/C/D (CN5). Firmly fix the wires by screwing down the terminals with a flat-heat screwdriver. 
Refer to the table below for motor connectivity: 

OUT_A A (Blue) 

OUT_B A
＿

 (White) 

OUT_C B (Yellow) 

OUT_D B
＿

 (Red) 

（Do not worry about incorrect wiring. Incorrect wiring will NOT cause any damage to hardware.） 

④ Connect the Arduino to a PC using a USB cable. 
⑤ Insert the AC Power adapter into the DC Jack on the baseboard. Be sure that a Center positive type 

adapter is being used with an output voltage 4-16V. 

If using power supply cables, please connect the positive terminal to VCC and the negative terminal to 
GND in the CN6 connector. The power supply terminals +/- at CN6 are polarity sensitive.(VCC=+, 
GND=-)

② 

①  

 

 

 

 

CN6 

CN5 

③ 

⑤ 

④ 

Motor Wiring 
 Diagram 
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How to use the GUI 
 
 

 
 

① Double-click the GUI shortcut located on the desktop 
and connect the COM serial port. 

 
 
Available COM ports will appear in the drop-down 
box. 
If the Arduino is connected correctly to the PC, an 
option for “Arduino Micro (COMx)” will be available 
(where x is the number associated with the port); 
select that COM port and click connect. 
 

② After connecting the Arduino, the GUI will 
automatically navigate to the LV8548Step tab 
 

③ Specify the desired motor excitation and direction of 
rotation 
 
 Excitation: 
   Full Step- Larger angle rotated per step 
   Half Step- Smaller angle rotated per step 
 Direction: 
  CW- Clockwise 
  CCW- Counter clockwise 
 
*Note: The direction of rotation may vary 
depending on how the motor wires are connected 
to the terminals  
 

 

 

 

 

 

④   Set the step angle for the motor 

 
 

*The step angle will vary depending on the motor.  
If using the included reference motor, please set it 
to 7.5° 

 

 

 

 

 

 

 

 

 

 

 

 

 

① 

② 

④ 

③ 

⑧ ⑨ 

⑦ 

⑥ 

⑤ 

⑭ 

⑪ 

⑪ 

⑩ 

⑫ ⑬ 
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The step angle setting enables the “rpm” setting 
under Motor Speed and “Degree” setting under 
Transfer Unit. 

 
 

 
 

⑤ Set the motor speed in step/s or rpm 

 step/s（=pps）: 

Frequency of the number of steps per second 

rpm: Rotational speed of the motor per minute 
 

Stepper motors are not intended for sudden 
acceleration, and will vibrate if the control exceeds 
the maximum rotation speed. When using the 
included reference motor with the recommended 
AC adaptor, please set the rotation speed 
according to the table below. 

Full Step 1～400 step/s 2～500 rpm 

Half Step 1～720 step/s 1～450 rpm 

 

⑥ Set the units and value of the transfer condition 

for the control signal. After the specified transfer 
condition elapses, the motor will stop and hold its 
torque. Since current continues to flow to the 
motor, it is important to pay attention to heat 
generation. Please select the Free button to stop 
powering the motor. 
For an unspecified rotation time, select 0 (Infinity) 
 

 

Example 1: Rotating the motor for 10 seconds 
Transfer Unit = Seconds 

Transfer Time = 10 [seconds] 

 
 

 

 

 

 

 

Example 2: Rotating the motor for 100 steps 
Transfer Unit = Steps 
Transfer Step = 100 [steps] 

 
 

Example 3: Rotating the motor 180 degrees 
Transfer Unit= Degree 
Transfer Angle= 180 [degree] 

 
 

⑦  When the Start button is pressed, the motor 
will rotate. If changes to the excitation method 
or motor speed are made, the changes will 
take effect upon pressing the Start button. 

 
To change the direction of rotation, it is 
recommended to stop the motor first with the 
Stop button, change the current value, and 
then press the Start button to begin the motor 
rotation.  
 
Pressing the Stop button causes the motor to 
stop, and hold the torque. 
When the Free button is pressed, the motor 
will stop and lose the torque. 
 
To maintain the position while the motor 
rotates, or to pause the motor and restart from 
the same position, select the Stop button. 
At this time, because of the current still flowing 
to the motor, attention must again be paid to 
heat generation. 

 
 

⑧GUI Language Settings 

⑨GUI Tool Tip Display 

⑩Help function 

See appendix for more information 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

⑪ Closing the GUI 
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When finished, exit the GUI by pressing the “Exit” 
button at the bottom right of the screen or by 
clicking “Exit” item at the top menu bar. 

 
 

 
 
The following popup message will be displayed 
when exiting the GUI.  

Select “Yes” to quit the GUI. 
Select “No” to cancel the exit and return to the main 
screen. 
 
If the GUI is closed while the motor is still running, 
the motor will be stopped and the window will 
close.  
 
For more details on the following features, refer to 
the next section on How to use the GUI Log: 
⑫ Saving the GUI log 
⑬ Clear the GUI log 
⑭ Program generation 
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How to use the GUI Log 

The log screen in the GUI shows the serial data sent to Arduino to control its API functions 

 
 
⑫ Saving the GUI Log 

By pressing the “SAVE” button, the content displayed on the work log can be saved as a .txt file or a .csv 
file. 

 
 

⑬ Clear GUI Log 
By pressing the “CLEAR” button, the content displayed on the work log will be erased. 
 

⑭  Program Generation 
Pressing the “Generate Program” will output the executed API functions on the work log into a .ino 
program file that can be uploaded directly with Arduino. By writing the output of the .ino file to Arduino, 
motor control can be executed automatically through standalone operation according to the procedure 
generated through the GUI Log. 
For more details regarding the Arduino program generation function, refer to the attached Appendix under 

⑭ Arduino Program Automatic Generation. 

 

i. Set Step Angle 

ii. Start Motor Rotation 

iii. Stop Motor Rotation 

iv. Free Motor Rotation 

i. Set Step  Angle 

Executed 

iv. Start Motor 

Rotation 

Executed 

⑫ ⑭ ⑬ 

iii. Stop Motor 

Rotation 

Executed 

ii. Free Motor 

Rotation 

Executed 
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