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Preface

INTRODUCTION
This chapter contains general information that will be useful to know before using the 
EVB-LAN9252_SAM D51. Items discussed in this chapter include:
• Document Layout
• Conventions Used in this Guide
• Warranty Registration
• The Microchip Website
• Development Systems Customer Change Notification Service
• Customer Support
• Document Revision History

DOCUMENT LAYOUT
This document features the EVB-LAN9252_SAM D51. The manual layout is as follows:
• Chapter 1. “Overview” – This chapter provides a brief description of the 

EVB-LAN9252_SAM D51.
• Chapter 2. “Getting Started” – This chapter provides information on the setup 

and operation of the EVB-LAN9252_SAM D51.
• Chapter 3. “Hardware Configuration” – This chapter includes information on 

the hardware configuration of the EVB-LAN9252_SAM D51.
• Appendix A. “Schematics” – This appendix shows the EVB-LAN9252_SAM 

D51 schematics.
• Appendix B. “Bill of Materials” – This appendix includes the 

EVB-LAN9252_SAM D51 Bill of Materials.
• Appendix C. “Silk Screens” – This appendix includes the EVB-LAN9252_SAM 

D51 silk screens.
• Appendix D. “Slave Stack Code Generation” – This appendix details the proce-

dure for generating a Slave Stack Code for EtherCAT operation on 
EVB-LAN9252_SAM D51.

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and 
documentation are constantly evolving to meet customer needs, so some actual dialogs and/or 
tool descriptions may differ from those in this document. Please refer to our web site 
(www.microchip.com) to obtain the latest documentation available.
Documents are identified with a “DS” number. This number is located on the bottom of each page, 
in front of the page number. The numbering convention for the DS number is “DSXXXXXA”, where 
“XXXXX” is the document number and “A” is the revision level of the document.
For the most up-to-date information on development tools, see the MPLAB® IDE online help. 
Select the Help menu, and then Topics to open a list of available online help files.
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CONVENTIONS USED IN THIS GUIDE
This manual uses the following documentation conventions:

DOCUMENTATION CONVENTIONS
Description Represents Examples

Arial font:
Italic characters Referenced books MPLAB® IDE User’s Guide

Emphasized text ...is the only compiler...
Initial caps A window the Output window

A dialog the Settings dialog
A menu selection select Enable Programmer

Quotes A field name in a window or 
dialog

“Save project before build”

Underlined, italic text with 
right angle bracket

A menu path File>Save

Bold characters A dialog button Click OK
A tab Click the Power tab

N‘Rnnnn A number in verilog format, 
where N is the total number of 
digits, R is the radix and n is a 
digit.

4‘b0010, 2‘hF1

Text in angle brackets < > A key on the keyboard Press <Enter>, <F1>
Courier New font:
Plain Courier New Sample source code #define START

Filenames autoexec.bat

File paths c:\mcc18\h

Keywords _asm, _endasm, static

Command-line options -Opa+, -Opa-

Bit values 0, 1

Constants 0xFF, ‘A’

Italic Courier New A variable argument file.o, where file can be 
any valid filename

Square brackets [ ] Optional arguments mcc18 [options] file 
[options]

Curly brackets and pipe 
character: { | }

Choice of mutually exclusive 
arguments; an OR selection

errorlevel {0|1}

Ellipses... Replaces repeated text var_name [, 
var_name...]

Represents code supplied by 
user

void main (void)
{ ...
}
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WARRANTY REGISTRATION
Please complete the enclosed Warranty Registration Card and mail it promptly.
Sending the Warranty Registration Card entitles users to receive new product updates.
Interim software releases are available at the Microchip website.

THE MICROCHIP WEBSITE
Microchip provides online support via our website at www.microchip.com. This website
is used as a means to make files and information easily available to customers. Acces-
sible by using your favorite Internet browser, the website contains the following infor-
mation:
• Product Support – Data sheets and errata, application notes and sample

programs, design resources, user’s guides and hardware support documents,
latest software releases and archived software

• General Technical Support – Frequently Asked Questions (FAQs), technical
support requests, online discussion groups, Microchip consultant program
member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip
press releases, listing of seminars and events, listings of Microchip sales offices,
distributors and factory representatives

DEVELOPMENT SYSTEMS CUSTOMER CHANGE NOTIFICATION SERVICE
Microchip’s customer notification service helps keep customers current on Microchip
products. Subscribers will receive e-mail notification whenever there are changes,
updates, revisions, or errata related to a specified product family or development tool of
interest.
To register, access the Microchip web site at www.microchip.com, click on Customer
Change Notification and follow the registration instructions.
The Development Systems product group categories are:
• Compilers – The latest information on Microchip C compilers, assemblers, linkers

and other language tools. These include all MPLABCC compilers; all MPLAB
assemblers (including MPASM™ assembler); all MPLAB linkers (including
MPLINK™ object linker); and all MPLAB librarians (including MPLIB™ object
librarian).

• Emulators – The latest information on Microchip in-circuit emulators.This
includes the MPLAB® REAL ICE™ and MPLAB ICE 2000 in-circuit emulators.

• In-Circuit Debuggers – The latest information on the Microchip in-circuit debug-
gers. This includes MPLAB ICD 3 in-circuit debuggers and PICkit™ 3 debug
express.

• MPLAB IDE – The latest information on Microchip MPLAB IDE, the Windows®

Integrated Development Environment for development systems tools. This list is
focused on the MPLAB IDE, MPLAB IDE Project Manager, MPLAB Editor and
MPLAB SIM simulator, as well as general editing and debugging features.

• Programmers – The latest information on Microchip programmers. These include
production programmers such as MPLAB REAL ICE in-circuit emulator, MPLAB
ICD 3 in-circuit debugger and MPLAB PM3 device programmers. Also included
are non-production development programmers such as PICSTART® Plus and
PICkit™ 2 and 3.
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CUSTOMER SUPPORT
Users of Microchip products can receive assistance through several channels:
• Distributor or Representative
• Local Sales Office
• Field Application Engineer (FAE)
• Technical Support
Customers should contact their distributor, representative or field application engineer 
(FAE) for support. Local sales offices are also available to help customers. A listing of 
sales offices and locations is included in the back of this document.
Technical support is available through the web site at: 
http://www.microchip.com/support

DOCUMENT REVISION HISTORY

Revisions Section/Figure/Entry Correction
DS50003012A 

(07-30-20)
Initial release
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Chapter 1. Overview

1.1 INTRODUCTION
The EVB-LAN9252_SAM D51 Evaluation Board is an EtherCAT slave controller with
dual integrated Ethernet PHYs. Each Ethernet PHY contains a Full-Duplex
100BASE-TX transceiver and supports 100 Mbps (100BASE-TX) operation.
The EVB-LAN9252_SAM D51 allows users to gain understanding of the product and
accelerate integration of the LAN9252 into their design. The evaluation platform sup-
ports two EtherCAT ports, and the SAMD51 processor enables the configuration of the
evaluation board for EtherCAT operation. The EVB is on a four-layer RoHS-compliant
Printed Circuit Board (PCB). For more information about EVB-LAN9252_SAM D51,
see Section 1.2 “Features”.

1.2 FEATURES
• Two-port 100BASE-TX Full-Duplex EtherCAT slave controller with integrated 

Ethernet PHYs
• LAN9252 in a 64-pin QFN RoHS-compliant package
• SAM D51 processor for EtherCAT configuration through EEPROM
• USB Micro-B connector for board power
• MikroBUS™ connection for external peripherals
• Two RJ-45 ports with LED link/activity indicators
• Atmel-ICE 10 pin-connector
• PICkit™ 4 8-pin header for SAM D51 programming

1.3 BLOCK DIAGRAM

FIGURE 1-1: EVB-LAN9252_SAM D51 BLOCK DIAGRAM
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1.4 REFERENCES
Concepts and materials available in the following documents may be helpful when 
reading this document. Visit www.microchip.com for the latest documentation.
• LAN9252 2/3-Port EtherCAT® Slave Controller with Integrated Ethernet PHYs 

Data Sheet
• SAM D5X/E5X Family Data Sheet
• AN 8.13 Suggested Magnetics
• EVB-LAN9252_SAM D51 Schematics
• AN1920 Microchip LAN9252 EEPROM Configuration and Programming Applica-

tion Note
• MPLAB® PICkit™ 4 In-Circuit Debugger User’s Guide

1.5 TERMS AND ABBREVIATIONS
The following are the terms and abbreviations used in this document:
• DNP – Do Not Populate
• EEPROM – Electrically Erasable Programmable Read-Only Memory
• ESC – EtherCAT Slave Controller
• EVB – Engineering Validation Board
• EtherCAT – Ethernet for Control Automation Technology
• IDE – Integrated Development Environment
• LOS – Loss of Signal
• RJ-45 - Ethernet Port
• SD – Signal Detect
• SPI – Serial Protocol Interface
• SSC – Slave Stack Code
• TwinCAT – EtherCAT Runtime System Tool
• USB – Universal Serial Bus
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Chapter 2. Getting Started

2.1 INTRODUCTION
The Microchip EVB-LAN9252_SAM D51 Evaluation Board is designed for flexible con-
figuration solutions. It can be configured via MPLAB Harmony, TwinCAT, and Slave 
Stack Coding Tools. Refer to Section 2.3 “Tools for EVB-LAN9252_SAM D51 Setup 
Procedure” for the tools needed to configure the board for EtherCAT functionality.

2.2 KIT CONTENTS
The EVB-LAN9252_SAM D51 Evaluation Board includes the basic equipment neces-
sary for evaluation. The items included in the board are:
• EVB-LAN9252_SAM D51 Evaluation Board
• Type-A to micro USB 2.0 cable

2.3 TOOLS FOR EVB-LAN9252_SAM D51 SETUP PROCEDURE
The following are the software and tools necessary for setting up the control or man-
agement PC and programming the EVB-LAN9252_SAM D51 Evaluation Board:
• Beckhoff TwinCAT Software
• Microchip MPLAB® X IDE (v5.30 or newer)
• Microchip XC32 Compiler
• Microchip PICKit™ 4 In-Circuit Debugger
• Microchip Harmony Plug-In (through MPLAB X IDE)
• EtherCAT® Slave Stack Code (Refer to Appendix D. “Slave Stack Code Gener-

ation”)
• GitHub MPLAB Harmony v3 EtherCAT repository, which provides detailed infor-

mation on creating an EtherCAT application using Harmony

On the board, jumpers are essential for the following:
• J6, positions 1-2
• J11

Note: The EVB-LAN9252_SAM D51 Evaluation Board requires a PICKit™ 4 
In-Circuit Debugger as additional hardware for configuration.
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Chapter 3.  Hardware Configuration

3.1 HARDWARE CONFIGURATION OPTIONS
Figure 3-1 shows the top view of the EVB-LAN9252_SAM D51 Evaluation Board.

FIGURE 3-1: EVB-LAN9252_SAM D51 EVALUATION BOARD (TOP VIEW)

3.1.1 Power
The EVB-LAN9252_SAM D51 can be powered by a USB cable or +5V supply. This 
delivers +5V and +3.3V supplies to the board. The +5V indication is provided by D4, 
while the +3.3V indication is provided by D5.

3.1.2 MikroBUS™

The EVB-LAN9252_SAM D51 supports click boards with an on-board MikroBUS™ 
connection. This allows for LCD displays, motor control, and other click board inter-
faces. To enable a click board, some settings need to be configured with the MCU.

3.1.3 Clocks
The EVB-LAN9252_SAM D51 Evaluation Board has the following three clocks: 
1. A 25 MHz reference crystal for LAN9252 (also has an option for 25 MHz oscilla-

tor) 
2. A 16 MHz crystal for SAM D51
3. A 32.768 KHz crystal for SAM D51

3.1.4 Ethernet Ports
The EVB-LAN9252_SAM D51 has two 100BASE-TX Ethernet ports for EtherCAT oper-
ation namely, J1 (PORT0 IN) and J2 (PORT1 OUT).
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3.1.5 LED Indicators
Table 3-1 describes the LED indicators on the EVB-LAN9252_SAM D51.

3.1.6 Switches
Table 3-2 describes the switches on the EVB-LAN9252_SAM D51.

TABLE 3-1: EVB-LAN9252_SAM D51 LED INDICATOR DESCRIPTIONS
Ref. Des. Label Description

D1 RST LAN Indicates LAN9252 Reset
D2 RUN Indicates LAN9252 RUN status

D3 ERROR Indicates LAN9252 ERROR status
D4 5V Illuminates when the 5V supply is present
D5 3V3 Illuminates when the 3.3V supply is present
D6 RST MCU Indicates SAM D51 Reset
J1 

(Green LED)
LINK0 Indicates the link status of Port 0

J2 
(Green LED)

LINK1 Indicates the link status of Port 1

TABLE 3-2: EVB-LAN9252_SAM D51 SWITCH DESCRIPTIONS
Ref. Des. Label Description

SW1 RST LAN Momentary push-button switch to assert LAN9252 Reset
SW2 RST MCU Momentary push-button switch to assert SAM D51 Reset
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3.1.7 Connector Descriptions
Table 3-3 describes the connectors included on the PCB.

3.1.8 Test Points
Table 3-4 describes the test points on the EVB-LAN9252_SAM D51. A header may be 
permanently installed on the through-hole test points if needed.

TABLE 3-3: EVB-LAN9252_SAM D51 CONNECTOR DESCRIPTIONS
Ref. Des. Type Label Description

J1 RJ-45 
Ethernet Port 

PORT0 IN 100BASE-TX Ethernet port for EtherCAT 
ingress traffic

J2 RJ-45 
Ethernet Port

PORT1 OUT 100BASE-TX Ethernet port for Ethernet 
egress traffic

J3 1x5 Header QSPI QSPI communication header
J4 1x3 Header I2C I2C communication to the I2C EEPROM. To 

enable, J6 must have jumper in positions 1 
and 2.

J5 1x8 Header PICKit-4 PICKit™ 4 programming header/port
J6 1x3 Header — Selects between EEPROM programming 

(positions 1 and 2) and JTAG (positions 2 
and 3).

J7 2x5 Header UART UART header to SAM D51. SAM D51 calls 
this Universal Synchronous and Asynchro-
nous Receiver and Transmitter (USART).

J8 Micro USB 
Connector

— USB connector for power through USB 
cable to connected device

J9 2x8 Header GPIO LAN9252 GPIO test header for all LAN9252 
GPIO signals (0 to15)

J10 2x5 Header SAM-ICE SAM-ICE™ programming port
J11 1x2 Header 5V +5V voltage supply header. In a closed posi-

tion, VBUS from J8 is used as the +5V sup-
ply. In an open position, external +5V must 
be applied to position 2.

J12 1x5 Header JTAG JTAG port. To enable, J6 must have jumper 
in positions 2 and 3.

J13 2x8 Header — SAM D51 input/output test header
J15 Micro Coax 

(UMC) Jack
SYNC0 SYNC0 reference to synchronize clocks

J16 Micro Coax 
(UMC) Jack

SYNC1 SYNC1 reference to synchronize clocks

Mikro-BUS1 MikroBUS™ 
Connector

MIKROBUS MikroBUS connection for click board con-
nection

TABLE 3-4: EVB-LAN9252_SAM D51 TEST POINT DESCRIPTIONS
Ref. Des. Type Description

TP4 Test Loop (Red) 1.2V oscillator supply
TP7 Test Loop (Red) 3.3V supply



EVB-LAN9252_SAM D51 Evaluation Board User’s Guide

DS50003012A-page 16  2020 Microchip Technology Inc.

NOTES:



EVB-LAN9252_SAM D51
EVALUATION BOARD

USER’S GUIDE

 2020 Microchip Technology Inc. DS50003012A-page 17

Appendix A. Schematics

A.1 INTRODUCTION
This appendix shows the EVB-LAN9252_SAM D51 Evaluation Board schematics.
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FIGURE A-1: EVB-LAN9252_SAM D51 SCHEMATIC 1
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FIGURE A-2: EVB-LAN9252_SAM D51 SCHEMATIC 2 
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FIGURE A-3: EVB-LAN9252_SAM D51 SCHEMATIC 3 
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Appendix B. Bill of Materials

B.1 INTRODUCTION
This appendix contains the EVB-LAN9252_SAM D51 Evaluation Board Bill of Materials (BOM).
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TABLE B-1: EVB-LAN9252_SAM D51 BILL OF MATERIALS (BOM)
Item Qty. Reference Description Populated Manufacturer Manufacturer Part Number

1 33 C1, C2, C13, C15, C16, C17, C18, 
C21, C22, C23, C24, C25, C26, C27, 
C28, C29, C30, C31, C33, C34, C35, 
C36, C37, C38, C39, C44, C45, C46, 
C47, C49, C50, C55, C59

CAP CER 0.1uF 16V 10% X7R SMD 0402 Yes Murata GRM155R71C104KA88D

2 8 C3, C4, C5, C6, C8, C9, C10, C11 CAP CER 10pF 50V 5% NP0 SMD 0402 DNP AVX Corporation 04025A100JAT2A

3 2 C7, C12 CAP CER 0.022uF 50V 10% X7R SMD 0402 Yes Murata Electronics GCM155R71H223KA55D

4 6 C14, C40, C41, C42, C43, C58 CAP CER 10uF 16V 10% X5R SMD 0805 Yes Murata GRM21BR61C106KE15L

5 6 C19, C20, C52, C53, C56, C57 CAP CER 10pF 50V 5% NP0 SMD 0402 Yes AVX Corporation 04025A100JAT2A

6 2 C32, C54 CAP CER 0.1uF 50V 10% X7R SMD 0402 DNP TDK Corporation C1005X7R1H104K050BB

7 1 C48 CAP CER 1uF 16V 10% X5R SMD 0603 Yes AVX 0603YD105KAT2A

8 1 C51 CAP CER 4.7uF 10V 10% X5R SMD 0603 Yes KEMET C0603C475K8PACTU

9 3 D1, D3, D6 DIO RED 2V 20mA 54mcd CLEAR SMD 0603 Yes Lite-On Inc. LTST-C191KRKT

10 3 D2, D4, D5 DIO LED GREEN 2V 30mA 35mcd Clear SMD 0603 Yes Lite-On Inc LTST-C191KGKT

11 5 FB1, FB2, FB3, FB4, FB5 FERRITE 220R@100MHz 1.4A SMD 0603 Yes Murata Electronics North 
America

BLM18PG221SN1D

12 2 J1, J2 CON MODULAR JACK RJ45 100 2xLEDS SHIELD TH R/A Yes Pulse Electronics Network J0011D01BNL

13 1 J3 CON HDR-2.54 Male 1x7 Gold 5.84MH TH VERT Yes Wurth Electronics Inc 61300711121

14 2 J4, J6 CON HDR-2.54 Male 1x3 Gold 5.84MH TH VERT Yes FCI 68000-103HLF

15 1 J5 CON HDR-2.54 Male 1x8 Gold 5.84MH TH Yes FCI 68001-108HLF

16 1 J7 CON HDR-2.54 Male 2x5 0.100" (2.54mm) TH VERT Yes Metz Connect PR20205VBDN

17 1 J8 CON USB2.0 MICRO-B FEMALE TH/SMD R/A Yes FCI 10118194-0001LF

18 2 J9, J13 CON HDR-2.54 Male 2x8 Gold 5.84MH TH VERT Yes FCI 68602-116HLF

19 1 J10 HDR 1.27mm 2x5 shrouded Yes CNC Tech 3220-10-0100-00

20 1 J11 CON HDR-2.54 Male 1x2 Gold 5.84MH TH VERT Yes FCI 77311-118-02LF

21 1 J12 CON HDR-2.54 Male 1x5 Gold 5.84MH TH VERT Yes FCI 68000-105HLF

22 2 J15, J16 CON RF Micro Coaxial U.FL Male 4P SMD VERT Yes Amphenol RF Division A-1JB

23 2 JP1, JP2 MECH HW JUMPER 2.54mm 1x2 MECH Sullins Connector Solutions QPC02SXGN-RC

24 1 L1 INDUCTOR 10uH 430mA 10% SMD 0805 DNP Coilcraft 0805PS-103KLC

25 1 mikroBUS 1 SOCKET mikroBUS HOST DIP 16 TH Yes Sullins Connector Solutions PPTC081LFBN-RC

26 12 R1, R5, R6, R8, R9, R11, R12, R20, 
R26, R30, R41, R42

RES TKF 10k 1% 1/10W SMD 0603 Yes Vishay CRCW060310K0FKEA

27 9 R2, R10, R18, R19, R37, R39, R44, 
R45, R55

RES TKF 2.2k 1% 1/10W SMD 0603 Yes Panasonic ERJ-3EKF2201V
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28 5 R3, R13, R25, R27, R61 RES TKF 330R 1% 1/10W SMD 0603 Yes ROHM, Panasonic MCR03EZPFX3300, 
ERJ-3EKF3300V

29 2 R4, R14 RES TKF 330R 1% 1/10W SMD 0603 DNP ROHM MCR03EZPFX3300

30 1 R7 RES TKF 12.1k 1% 1/10W SMD 0603 Yes Panasonic ERJ-3EKF1212V

31 8 R15, R46, R47, R48, R50, R51, R52, 
R53

RES TKF 49.9R 1% 1/10W SMD 0603 Yes Panasonic ERJ-3EKF49R9V

32 10 R16, R17, R22, R28, R33, R34, R36, 
R38, R49, R54

RES TKF 0R 1/10W SMD 0603 Yes Panasonic ERJ-3GSY0R00V

33 2 R21, R35 RES TKF 0R 1/10W SMD 0603 DNP Panasonic ERJ-3GSY0R00V

34 6 R23, R24, R56, R57, R58, R59 RES TKF 33R 1% 1/10W SMD 0603 Yes ROHM MCR03EZPFX33R0

35 2 R29, R40 RES TKF 1k 1% 1/10W SMD 0603 Yes Panasonic ERJ-3EKF1001V

36 1 R31 RES TKF 84.5k 1% 1/10W SMD 0603 Yes Yageo RC0603FR-0784K5L

37 1 R32 RES TKF 12k 1% 1/10W SMD 0603 Yes Yageo RC0603FR-0712KL

38 1 R60 RES TRIMMER 10k 25% 0.1W SMD TC33 Yes Bourns Inc. TC33X-2-103E

39 2 SW1, SW2 SWITCH TACT SPST 16V 50mA PTS810 SJM 250 SMTR LFS 
SMD

Yes C&K Components PTS810 SJM 250 SMTR LFS

40 5 TP3, TP6, TP10, TP12, TP13 MISC, TEST POINT MULTI PURPOSE MINI WHITE DNP Keystone 5002

41 2 TP4, TP7 MISC, TEST POINT MULTI PURPOSE MINI RED Yes Keystone 5000

42 2 TP5, TP9 MISC, TEST POINT PC MINI, 0.040" D YELLOW DNP Keystone 5004

43 1 U1 MCHP INTERFACE ETHERNET LAN9252I/ML 64QFN Yes Microchip Technology LAN9252I/ML

44 1 U2 MCHP MCU 32-BIT 120MHz 1MB ATSAMD51J19A-MFT 
VQFN-64

Yes Microchip Technology ATSAMD51J19A-MFT

45 1 U3 MCHP MEMORY SERIAL EEPROM 512kb 1MHZ I2C 
24FC512T-I/SN SOIC-8

Yes Microchip Technology 24FC512T-I/SN

46 1 U4 IC TRANSCEIVER MAX3232 SSOP-16 Yes Texas Instruments MAX3232CDBR

47 1 U5 MCHP ANALOG LDO ADJ MCP1825T-ADJE/DC SOT-223-5 Yes Microchip MCP1825T-ADJE/DC

48 2 U6, U7 74LVC1G14GW,125 SCHMITT-TRG INVERTER Yes NXP 74LVC1G14GW,125

49 1 Y1 CRYSTAL 25MHz 10pF SMD ABM8G Yes Abracon LLC ABM8G-25.000MHZ-4Y-T3

50 1 Y2 CRYSTAL 16MHz 9pF 26ppm SMD L3.2W2.5H0.6 Yes AVX Corp/Kyocera Corp CX3225SB16000E0FPZ25

51 1 Y3 CRYSTAL 32.768KHz 12.5pF SMD L3.2W1.5H0.9 Yes Fox Electronics FK135EIHM0.032768-T3

TABLE B-1: EVB-LAN9252_SAM D51 BILL OF MATERIALS (BOM) (CONTINUED)
Item Qty. Reference Description Populated Manufacturer Manufacturer Part Number
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Appendix C. Silk Screens

C.1 INTRODUCTION
This appendix shows the top and bottom silk screen images of the EVB-LAN9252_SAM D51 Evaluation 
Board.
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FIGURE C-1: EVB-LAN9252_SAM D51 TOP SILK SCREEN IMAGE
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FIGURE C-2: EVB-LAN9252_SAM D51 BOTTOM SILK SCREEN IMAGE 
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Appendix D. Slave Stack Code Generation

D.1 INTRODUCTION
This appendix details the procedure for generating the Slave Stack Code for EtherCAT operation on the
EVB-LAN9252_SAM D51 Evaluation Board.

D.2 SLAVE STACK CODE GENERATION
Perform the following steps to generate the slave stack code:
1. Download the Slave Stack Code (SCC) tool from EtherCAT.org website. An EtherCAT membership is 

necessary for downloading the code.
2. Install the SSC tool on the control or management PC.
3. Open the SSC tool and navigate to File>New to create a new project.
4. Select Custom and then click on Import. See Figure D-1.

FIGURE D-1: SLAVE STACK CODE GENERATION – IMPORT CONFIGURATION FILE
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5. Import the Microchip-SAMD51-LAN925x-SSC_Config.xml configuration file from <Harmony 
Directory>\ethercat\apps\ethercat_counter_foe_app\firm-
ware\src\slave_stack. After importing this configuration file, the Microchip SAM D51 will appear 
in the “Custom” field. Select this and click on OK. Click on Yes for the next two prompts. See 
Figure D-2.

FIGURE D-2: SLAVE STACK CODE GENERATION – NEW PROJECT CREATION

6. Navigate to the <Harmony Directory>\ethercat\apps\ethercat_counter_-
foe_app\firmware\src\config\sam_d51_lan9252_evb\driver\lan9252 directory to 
point to the drv_lan9252.c file and click on Open. This will load the code. 
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7. Go to Tools>Application>Import Application. In the “Application name” field, enter “sample_app” in the 
<Harmony Directory>\ethercat\apps\ethercat_counter_foe_app\firm-
ware\src\slave_stack. Click on OK. See Figure D-3.

FIGURE D-3: SLAVE STACK CODE GENERATION – IMPORT APPLICATION FILE
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8. Go to Tools>Create New Slave Files. When prompted to save the project, save it in the directory pro-
vided. Click on the Start button to create the slave files. When complete, click on the Open Folder to 
open a window with all of the slave files. See Figure D-4.

FIGURE D-4: SLAVE STACK CODE GENERATION – CREATE NEW SLAVE FILES

9. Copy these files from the directory in the previous step (including the sample_app.c, sam-
ple_app.h, sample_appObject.h and the SAMD51 EtherCAT Slave.xml files) and paste 
them to the <Harmony Directory>\ethercat\slave_stack directory.
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