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Toolchain Installation for Keil µVision5

General Overview

410/25/2021

Download and install 

Keil µVision5

Download
Infineon Developer 

Center

and Config Wizard

Download 

and install 

Segger 

J-Link Driver

Download 

the SDK via 

µVision5 

Pack Installer
(See step 1)

STEP1 STEP2 STEP3 STEP4

Arm® Keil µVision is an integrated 

development environment which 

consists of code editor, compiler and 

debugger.

SEGGER J-Link is a widely 

used driver for on-board or 

stand-alone debuggers.

The Embedded Power Software 

Development Kit (SDK) is a low level 

driver library which can be downloaded 

within the Pack Installer for Keil µVision5.

MOTIX™ Embedded Power ICs are supported by a complete 

development toolchain provided by Infineon and third party vendors. 

Infineon provides the Infineon 

Developer Center which is designed to 

install and use Infineon plugins and 

tools. Config Wizard allows easy 

configuration of chip modules. 

Copyright © Infineon Technologies AG 2021. All rights reserved.



Toolchain installation for Keil µVision5

Step 1: Keil µVision5

510/25/2021

Pack Installer

Keil µVision5

› For downloading, installing, updating and

managing the different software packages

› Quick access to example projects that can be

used as a reference for own development

› Software development environment for Arm®

Cortex-M® based microcontroller devices

› Code editor, online debugger and Arm C/C++

compiler

› Download from: https://www.keil.com/demo/eval/arm.htm

Copyright © Infineon Technologies AG 2021. All rights reserved.



Toolchain installation for Keil µVision5

Step 2: Infineon Developer Center and Config Wizard (1)

610/25/2021

Infineon Developer Center & Config Wizard for MOTIX™ MCU

› Install the Infineon Developer Center and start the tool

› Within the Infineon Developer Center:

1. Select the tab Manage tools, search for Config Wizard for MOTIX™ MCU and click on Install

(*)

Copyright © Infineon Technologies AG 2021. All rights reserved.

(*)  For more information about the Infineon Developer Center installation, please refer to the Installation Manual.

MOTIX™ MCU

MOTIX MCU



Toolchain installation for Keil µVision5

Step 2: Infineon Developer Center and Config Wizard (2)

710/25/2021

Infineon Developer Center & Config Wizard for MOTIX™ MCU

2. Start the tool Config Wizard for MOTIX™ MCU once to trigger the integration into Keil µVision5

3. Close Config Wizard and the Infineon Developer Center

Copyright © Infineon Technologies AG 2021. All rights reserved.

› Config Wizard for MOTIX™ MCU enables the easy 

configuration of Automotive Embedded Power IC products.

MOTIX™



Toolchain installation for Keil µVision5

Step 3: Segger J-Link Driver

› Driver for 'on-board' or 'stand-alone' debugger

› Install driver from: 
https://www.segger.com/downloads/jlink/JLink_Wi

ndows.exe

Segger J-Link Driver

Copyright © Infineon Technologies AG 2021. All rights reserved. 810/25/2021



Toolchain installation for Keil µVision5

Step 4: Pack File

› Includes SDK (Software Development Kit) and 

Example code

› Device support for flashing/erasing 

› SFR description for register debugging

› Device description for Config Wizard

1. From Keil µVision5, open the Pack Installer

2. On the left side, select Infineon

3. On the right side, install the pack 

Infineon::TLE987x_DFP

1

2

3

Pack File TLE986x and TLE987x for Keil µVision5

Copyright © Infineon Technologies AG 2021. All rights reserved. 910/25/2021
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Toolchain Installation for IAR Embedded Workbench

General Overview

1110/25/2021

Download and install

IAR Embedded 

Workbench

Download
Infineon Developer 

Center

and Config Wizard

Download 

and install 

Segger 

J-Link Driver

Import the SDK via the

CMSIS Manager for 

IAR Embedded 

Workbench
(See step 1)

STEP1 STEP2 STEP3 STEP4

IAR Embedded Workbench is an 

integrated development environment 

which consists of code editor, 

compiler and debugger.

SEGGER J-Link is a widely 

used driver for on-board or 

stand-alone debuggers.

The Embedded Power Software 

Development Kit (SDK) is a low level 

driver library which can be imported into 

the CMSIS Manager for IAR Embedded 

Workbench..

MOTIX™ Embedded Power ICs are supported by a complete 

development toolchain provided by Infineon and third party vendors. 

Infineon provides the Infineon 

Developer Center which is designed to 

install and use Infineon plugins and 

tools. Config Wizard allows easy 

configuration of chip modules. 

Copyright © Infineon Technologies AG 2021. All rights reserved.



Toolchain Installation for IAR Embedded Workbench

Step 1: IAR Embedded Workbench for ARM

1210/25/2021

CMSIS Manager

IAR Embedded Workbench for ARM

› For importing, updating and managing the

different software packages

› Quick access to example projects that can be

used as a reference for own development

› Software development environment for Arm®

Cortex-M® based microcontroller devices

› Code editor, online debugger and Arm C/C++

compiler

› Download from: https://www.iar.com/products/architectures/arm/iar-embedded-workbench-for-arm/

Copyright © Infineon Technologies AG 2021. All rights reserved.



Toolchain installation for IAR Embedded Workbench

Step 2: Infineon Developer Center and Config Wizard (1)

1310/25/2021

Infineon Developer Center & Config Wizard for MOTIX™ MCU

› Install the Infineon Developer Center and start the tool

› Within the Infineon Developer Center:

1. Select the tab Manage tools, search for Config Wizard for MOTIX™ MCU and click on Install

(*)

Copyright © Infineon Technologies AG 2021. All rights reserved.

(*)  For more information about the Infineon Developer Center installation, please refer to the Installation Manual.

MOTIX™ MCU

MOTIX MCU



Toolchain Installation for IAR Embedded Workbench

Step 2: Infineon Developer Center and Config Wizard (2)

1410/25/2021

Infineon Developer Center & Config Wizard for MOTIX™ MCU

2. Start the tool Config Wizard for MOTIX™ MCU by clicking on Start

3. Close Config Wizard and the Infineon Developer Center

Copyright © Infineon Technologies AG 2021. All rights reserved.

› Config Wizard for MOTIX™ MCU enables the easy 

configuration of Automotive Embedded Power IC products.

MOTIX™



Toolchain Installation for IAR Embedded Workbench

Step 2: Infineon Developer Center and Config Wizard (3)

1510/25/2021

Infineon Developer Center & Config Wizard for MOTIX™ MCU

› Unlike for Keil µVision5, the Config Wizard is not 

integrated automatically into the IAR Embedded 

Workbench.

1. Select the tab Tools > Configure Tools…

2. Define a name and set up the following:

› Command: Path to the tool exe

› Argument (from Config Wizard v2.6.4): 

"$PROJ_DIR$\RTE\Device\$D$\config.icwp" -

ddevice=$D$

› Tool Available: Always

3. Click on OK

2

3

Copyright © Infineon Technologies AG 2021. All rights reserved.



Toolchain Installation for IAR Embedded Workbench

Step 2: Infineon Developer Center and Config Wizard (4)

1610/25/2021

Infineon Developer Center & Config Wizard for MOTIX™ MCU

4. Click on Tools > Configure Custom Argument 

Variables… to define the variable $D$ in the argument 

phrase

5. Select the tab Global, then define a name for the New 

Group… (here, Device)

6. Click on Add Variable… and define its name (here, D) 

and its value (here, TLE9879QXA40)

7. Click twice on OK to save your settings

8. Config Wizard is now fully accessible

5

6

5

7

7

6

Copyright © Infineon Technologies AG 2021. All rights reserved.



Toolchain Installation for IAR Embedded Workbench

Step 3: Segger J-Link Driver

› Driver for 'on-board' or 'stand-alone' debugger

› Install driver from: 
https://www.segger.com/downloads/jlink/JLink_Wi

ndows.exe

Segger J-Link Driver

Copyright © Infineon Technologies AG 2021. All rights reserved. 1710/25/2021



Toolchain Installation for IAR Embedded Workbench

Step 4: Pack File

› Includes SDK and Example code

› Device support for flashing/erasing 

› SFR description for register debugging

› Device description for Config Wizard

1. Open the CMSIS Manager

2. On the right side, select Import Existing Packs… 

and import the pack from your local disk (all 

packs are available here, under Infineon)

3. The tab Devices shows the supported devices

4. The tab Examples shows the examples

1

Pack File TLE987x for IAR Embedded Workbench

2

3

4

Copyright © Infineon Technologies AG 2021. All rights reserved. 1810/25/2021
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Getting Started with Keil µVision5

Infineon Embedded Power SDK

› Create new project with 

Infineon SDK

› Write code

› Initialize modules

› Set up Timers

› Set up GPIOs

› Connect device

› Program flash

› Use of debug window

J-Link ConfigurationKeil µVision5 Template Infineon Config Wizard

Copyright © Infineon Technologies AG 2021. All rights reserved. 2010/25/2021



Getting Started with Keil µVision5

Step 1: Create New Project

› Open Keil MDK

› Select Project > New µVision Project

› Name the project: (“TIMER2BLINK”)

1) Create New Project

› Select the device

› e.g. TLE9879QXA40 for TLE9879_EVALKIT

Copyright © Infineon Technologies AG 2021. All rights reserved. 2110/25/2021



Getting Started with Keil µVision5

Step 2: Configure the Run-Time Environment

1. Expand Device

› Check ConfigWizard_v2

› Check Startup

➢ The selected cell background is orange

2. Click on Resolve

➢ The selected cell background is green

3. Click on OK

1

2

3

2) Configure the Run-Time Environment

Copyright © Infineon Technologies AG 2021. All rights reserved.Copyright © Infineon Technologies AG 2021. All rights reserved. 2210/25/2021



Getting Started with Keil µVision5

Step 3: Use the main.c template

1. Expand Target 1

2. Right click on Source Group 1

3. Choose Add New Item to Group ‘Source 

Group 1’

4. Choose User Code Template

5. Expand Device

› Choose Startup

6. Click on Add

1

3

4

5

6

3) Use the main.c Template

2

Copyright © Infineon Technologies AG 2021. All rights reserved. 2310/25/2021



Getting Started with Keil µVision5

Step 4: Compile the Project

1. Compile Project:

› Press the Build button or press F7

2. The Build Output window shows 

0 Error(s) , 0 Warning(s)

4) Compile the Project

1

2

Copyright © Infineon Technologies AG 2021. All rights reserved. 2410/25/2021



Getting Started with Keil µVision5

Step 5: Add Modules from the Run-Time Environment

1. Click on Manage Run-Time Environment

2. Expand Device, then the SDK section

3. Select TIMER2x and click OK

4. Add code to the main.c file:

i. Include Libraries

ii. Initialize Modules

5) Add Modules from the Run-Time Environment

2

3

i

ii

Copyright © Infineon Technologies AG 2021. All rights reserved. 2510/25/2021



Getting Started with Keil µVision5

Step 6: Use the Config Wizard v2 (1)

1. Select the tab Tools

2. Open Config Wizard v2

3. Config Wizard opens in a separate window

6) Use the Config Wizard v2 (1)

2

1

3

Copyright © Infineon Technologies AG 2021. All rights reserved. 2610/25/2021



Getting Started with Keil µVision5

Step 6: Use the Config Wizard v2 (2)

1. Select the tab PORT

2. Go to the Port0 > Pin2 section

3. Configure pin to Output mode

4. Save with File > Save

6) Use the Config Wizard v2 (2)

3

2

1

4

Copyright © Infineon Technologies AG 2021. All rights reserved. 2710/25/2021



Getting Started with Keil µVision5

Step 6: Use the Config Wizard v2 (3)

1. Click on the tab Timer2x

2. Enable the checkbox Configure Timer2

3. In the section Clock Setting:

› Enable the prescaler and select divide by 128

4. In the section Reload / Capture Register: 

› Select …as time[us] and enter 100000.00 us

5. In the section Interrupt:

› Enable the checkboxes Overflow / Underflow 

Interrupt and Enable Interrupt

› Call Back Name: task_100ms

6. Save with File > Save

6) Use the Config Wizard v2 (3)

Copyright © Infineon Technologies AG 2021. All rights reserved. 2810/25/2021

1

2

3

4

6

5



Getting Started with Keil µVision5

Step 7: Edit the File main.c

In the file main.c in Keil MDK:

1. Start Timer2 before the “for (;;)” loop

2. Declare and define the function of the 

interrupt call back

› Use API function “PORT_ChangePin()”

3. Save and build (F7) the project

1

2

3

7) Edit the File main.c

Copyright © Infineon Technologies AG 2021. All rights reserved. 2910/25/2021



Getting Started with Keil µVision5

Step 8: Power up the Evaluation Board

› Connect micro USB cable

› Supply board via banana jacks (VBAT, 

GND)

› Debug LED lights up 

8) Power up the Evaluation Board

Copyright © Infineon Technologies AG 2021. All rights reserved. 3010/25/2021



Getting Started with Keil µVision5

Step 9: Connect the Debugger

1. Click on Options for Target

2. Click on the tab Debug and select J-Link

3. Click on Settings and set up the following:

› Port: SW

› Connect: with Pre-Reset

› Reset: Normal

➢ SWD connection established when 

“IDCODE” is visible 

2

9) Connect the Debugger

3

Copyright © Infineon Technologies AG 2021. All rights reserved. 3110/25/2021



Getting Started with Keil µVision5

Step 10: Download and Run Code

1. Load the code into the target or press F8

› Flash Load finished is shown in the 

Build Output window

2. Press the Reset button on the evaluation 

board

3. The LED on Port P0.2 lights up

4. The port toggles every 100 ms

100ms

10) Download and Run Code

1

2

3

4

Copyright © Infineon Technologies AG 2021. All rights reserved. 3210/25/2021



Getting Started with Keil µVision5

Step 11: Use the Runtime Debug

1. Click on Start/Stop Debug Session

2. Left click in the dark grey area left of the 

code to place a breakpoint

3. Click on Run or press F5 to start the code 

execution

4. The code is executed and stops at the 

breakpoint

› In this example, every time you click on Run, 

the LED P0.2 is toggled

2

3

4

11) Use the Runtime Debug

Copyright © Infineon Technologies AG 2021. All rights reserved. 3310/25/2021
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Getting Started with IAR Embedded Workbench

Infineon Embedded Power SDK

› Create new project with 

Infineon SDK

› Write code

› Initialize modules

› Set up Timers

› Set up GPIOs

› Connect device

› Program flash

› Use of debug window

J-Link Configuration
IAR Embedded 

Workbench Template
Infineon Config Wizard

Copyright © Infineon Technologies AG 2021. All rights reserved. 3510/25/2021



Getting Started with IAR Embedded Workbench

Step 1: Create New Project

› Open IAR Embedded Workbench

› Select a workspace to contain your 

project

› Select Project > Create New Project…

› Select Empty CMSISPack project

› Name the project: (“TIMER2BLINK”)

› Select the device

› e.g. TLE9879QXA40 for 

TLE9879_EVALKIT

1) Create New Project

Copyright © Infineon Technologies AG 2021. All rights reserved. 3610/25/2021



Getting Started with IAR Embedded Workbench

Step 2: Configure the Run-Time Environment

In the TIMER2BLINK.rteconfig file that opens in 

the CMSIS Manager:

1. Expand Device

› Check ConfigWizard_v2

› Check Startup

➢ The selected cell background is orange

2. Click on Resolve

➢ The selected cell background is green

3. Save your configuration: the selected 

modules appear under the section CMSIS-

Pack in your workspace

3

2) Configure the Run-Time Environment

2

1

Copyright © Infineon Technologies AG 2021. All rights reserved.Copyright © Infineon Technologies AG 2021. All rights reserved. 3710/25/2021



Getting Started with IAR Embedded Workbench

Step 3: Use the main.c template (1)

In the CMSIS Manager:

1. Open the menu CMSIS Manager and select 

Create files from CMSIS Template…

2. Select the project TIMER2BLINK

3. Expand Device and select Startup/Simple 

Main

4. Browse for the file location

5. Click on Finish

The file was added to your project but still does 

not appear in your workspace.

1

2

3

4

5

3) Use the main.c Template (1)

Copyright © Infineon Technologies AG 2021. All rights reserved. 3810/25/2021



Getting Started with IAR Embedded Workbench

Step 3: Use the main.c template (2)

In your workspace:

1. Right click on the project name and select 

Add > Add Files… 

➢ Select the main.c file in the Windows 

Explorer and click on Open

2. The main.c file is visible in your project

1

2

3) Use the main.c Template (2)

Copyright © Infineon Technologies AG 2021. All rights reserved. 3910/25/2021



Getting Started with IAR Embedded Workbench

Step 4: Compile the Project

1. Compile the project:

› Press the Make button or press F7

2. The Build window shows 

0 Error(s) , 0 Warning(s)

4) Compile the Project

1

2

Copyright © Infineon Technologies AG 2021. All rights reserved. 4010/25/2021



Getting Started with IAR Embedded Workbench

Step 5: Add Modules from the Run-Time Environment

In the TIMER2BLINK.rteconfig file in the CMSIS 

Manager:

1. Expand Device, then the SDK section

2. Select TIMER2x and save your configuration

3. Add code to the main.c file:

i. Include Libraries

ii. Initialize Modules

5) Add Modules from the Run-Time Environment

1

2

i

ii

Copyright © Infineon Technologies AG 2021. All rights reserved. 4110/25/2021



Getting Started with IAR Embedded Workbench

Step 6: Use the Config Wizard v2 (1)

1. Select the tab Tools

2. Open Config Wizard v2

3. Config Wizard opens in a separate window

6) Use the Config Wizard v2 (1)

2

1

3

Copyright © Infineon Technologies AG 2021. All rights reserved. 4210/25/2021



Getting Started with IAR Embedded Workbench

Step 6: Use the Config Wizard v2 (2)

1. Select the tab PORT

2. Go to the Port0 > Pin2 section

3. Configure pin to Output mode

4. Save with File > Save

6) Use the Config Wizard v2 (2)

3

2

1

4

Copyright © Infineon Technologies AG 2021. All rights reserved. 4310/25/2021



Getting Started with IAR Embedded Workbench

Step 6: Use the Config Wizard v2 (3)

1. Click on the tab Timer2x

2. Enable the checkbox Configure Timer2

3. In the section Clock Setting:

› Enable the prescaler and select divide by 128

4. In the section Reload / Capture Register: 

› Select …as time[us] and enter 100000.00 us

5. In the section Interrupt:

› Enable the checkboxes Overflow / Underflow 

Interrupt and Enable Interrupt

› Call Back Name: task_100ms

6. Save with File > Save

6) Use the Config Wizard v2 (3)

Copyright © Infineon Technologies AG 2021. All rights reserved. 4410/25/2021
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Getting Started with IAR Embedded Workbench

Step 7: Edit the File main.c

In the file main.c in Keil MDK:

1. Start Timer2 before the “for (;;)” loop

2. Declare and define the function of the 

interrupt call back

› Use API function “PORT_ChangePin()”

3. Save and build (F7) the project

1

23

7) Edit the File main.c

Copyright © Infineon Technologies AG 2021. All rights reserved. 4510/25/2021



Getting Started with IAR Embedded Workbench

Step 8: Power up the Evaluation Board

› Connect micro USB cable

› Supply board via banana jacks (VBAT, 

GND)

› Debug LED lights up 

8) Power up the Evaluation Board

Copyright © Infineon Technologies AG 2021. All rights reserved. 4610/25/2021



Getting Started with IAR Embedded Workbench

Step 9: Connect the Debugger

1. Right click on the project name and select 

Options

2. Select the category Debugger, then the 

driver J-Link/J-Trace

3. In the category J-Link/J-Trace, the following 

setups should be per default:

› Setup: Reset > Normal

› Setup: SWD speed > Auto

› Connection: Interface > SWD

2

9) Connect the Debugger

3

Copyright © Infineon Technologies AG 2021. All rights reserved. 4710/25/2021



Getting Started with IAR Embedded Workbench

Step 10: Download and Run Code

1. Select Project > Download > Download 

active application to load the code into the 

target

› Flash download is shown in the 

Debug Log window

➢ You can also click on          to download the 

code into the target and start a debug 

session

2. Press the Reset button on the evaluation 

board

3. The LED on Port P0.2 lights up

4. The port toggles every 100ms

100ms

10) Download and Run Code

1

3

4

Copyright © Infineon Technologies AG 2021. All rights reserved. 4810/25/2021



Getting Started with IAR Embedded Workbench

Step 11: Use the Runtime Debug

1. Click on Download and Debug

2. Left click in the dark grey area left of the 

code to place a breakpoint

3. Click on Go or press F5 to start the code 

execution

4. The code is executed and stops at the 

breakpoint

› In this example, every time you click on Run, 

the LED P0.2 is toggled

2

3

4

11) Use the Runtime Debug

Copyright © Infineon Technologies AG 2021. All rights reserved. 4910/25/2021
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MOTIX™ MCU

Product Portfolio

MOTIX™ Embedded Power ICs Product Portfolio

based on Arm® Cortex®-M processor

Smart Relay IC 
DC Motor

Smart Half Bridge Smart H-Bridge Driver Smart BLDC Driver IC

TLE9842/3/4

› Window Lift

› Sunroof

› Wiper

TLE9845/TLE9851

› HVAC Fan

› Engine Cooling Fan

› Fuel Pump

› Water Pump

TLE985x/TLE986x TLE987x

› Window Lift

› Sunroof

› Wiper

› Power Folding Roof

› Power Sliding Door

› Power Trunk/ Tailgate

› Fuel Pump

› HVAC Fan

› Engine Cooling Fan

› Water Pump

› Oil Pump

› Sunroof

› Wiper

10/25/2021 Copyright © Infineon Technologies AG 2021. All rights reserved. 51



MOTIX™ MCU

Evalboard and Evalkit Overview for TLE986x

TLE9869QX – Evaluation Kit

› H-Bridge N-MOS Bridge 

› Integrated LIN

› External LIN Transceiver

› RS232

› Debug LEDs

› Debug Connector SWD

› J-Link Lite Debugger

TLE986x EVALB_JLINK: SP001253678

TLE986x – 2-Phase Board with Socket

› 2-Phase N-MOS Bridge

› Single Shunt in GND path

› Integrated LIN (inside device)

› Virtual Com Port via J-Link

› Debug LEDs

› Onboard Segger J-Link Debugger

TLE9869 EVALKIT: SP001388252

10/25/2021 Copyright © Infineon Technologies AG 2021. All rights reserved. 52



MOTIX™ MCU

Evalboard and Evalkit Overview for TLE987x

TLE9879QX – Evaluation Kit

› 3-Phase N-MOS Bridge 

› Integrated LIN

› External LIN Transceiver

› RS232

› Debug LEDs

› Debug Connector SWD

› J-Link Lite Debugger

TLE987x EVALB_TQFP: SP005421936

TLE987x EVALB_VQFN: SP005421934

TLE987x – 3-Phase Board with Socket

› 3-Phase N-MOS Bridge

› Single Shunt in GND path

› Integrated LIN (inside device)

› Virtual Com Port via J-Link

› Debug LEDs

› Onboard Segger J-Link Debugger

TLE9879 EVALKIT: SP001389172

TLE987x EVALB_TQFP TLE987x EVALB_VQFN
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Product Information Links

5510/25/2021

› Embedded Power IC Overview

› TLE986xQX Overview 
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